21:32 - Wednesday, 23 April 2014

How Do I Install The Instant Messaging Application IP Messenger?

#Topics: how do i apply for instant messaging

I’ve recently downloaded g2ipmsg (IP Messenger for Ubuntu 11.10).

However – this comes not as an installable package as previous ubuntu versions.

Thus I think I need to compile it. This application needs gtk so I’ve installed libgtk2.0-dev using Synaptic Package Manager.

Now when I run ./configure command it gives me the following error.

checking for APPLET… configure: error: Package requirements (libpanelapplet-2.0) were >not met:

No package 'libpanelapplet-2.0' foundConsider adjusting the PKG_CONFIG_PATH environment variable if youinstalled software in a non-standard prefix.Alternatively, you may set the environment variables APPLET_CFLAGS andAPPLET_LIBS to avoid the need to call pkg-config. See the pkg-configman page for more details.

Where can I find the path for PKG_CONFIG_PATH?

This is what I have done so far:

I’ve installed libxml-parser-perl, libgnomeui-dev, gettext, intltool according to the post
Installing IP messenger on Ubuntu linux but could not find the package libpanel-applet2-dev.

Then I even tried to install libpanelappletmm-2.6-dev and libpanelappletmm-2.6-1c2 but could not find this packages

but still get the same error

configure: error: Package requirements (libpanelapplet-2.0) were not met


There are lot of problems with g2ipmsg in ubuntu, specially there are lot of problems during file transfer.

Instead of installing Ip messanger using wine or g2ipmsg use Iptux.

Its perfectly compatible with Ip Messanger.

Installing Iptux
sudo apt-get install iptux

The package g2ipmsg is available in the repositories – v0.9.6 for all versions of ubuntu except for oneiric. Thus to install in versions prior to oneiric or for 12.04 and above:

g2ipmsg Install g2ipmsg

However its not available in Oneiric (11.10) because it doesnt compile under oneiric due to the changes to Gnome-Panel and the dependency on the gnome-2 applet libraries.

You could compile and install to produce this result in gnome-classic (no-effects)

enter image description here

Note – when the application starts – it starts minimised to the gnome-panel. For some reason, in Unity, this application does not appear – probably the minimised application is not directly visible in the Unity panel.

To get the application to work under Unity you need to enable the old sys-tray:

gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"

Then logout and login before searching for g2ipmsg in Dash

I’ve compiled and added this to my PPA. If you wish to compile this yourself, then instructions are below.

Install from PPA

sudo add-apt-repository ppa:fossfreedom/g2ipmsgsudo apt-get updatesudo apt-get install g2ipmsg

to run g2ipmsg

  1. If you are using the Gnome-Classic interface, then G2ipmsg will be found in the Accessories menu option
  2. If you are using Gnome-Shell then search in Activities for g2ipmsg and the application will start minimized in the system-tray notification area (bottom right) of the screen. You will need to move you mouse to that area to make the application icon visible. My recommendation would be to use the system-tray extension to make the application icon visible at all times in the top-right of the screen. See my link answer below for more information about these areas and how to install the extension
  3. If you are using Unity/Unity 2D you will need to manually enable the system-tray area for the application to start in the top-right area of the screen next to the indicator area.

how to compile

  • Get the sources:
cd ~/Downloadswget https://launchpad.net/ubuntu/+archive/primary/+files/g2ipmsg_0.9.6%2Bdfsg.orig.tar.gzwget https://launchpad.net/ubuntu/+archive/primary/+files/g2ipmsg_0.9.6%2Bdfsg-1.1.diff.gz
  • Now install some prerequisites and libraries
sudo apt-get install build-essential devscripts cdbs debhelper autotools-dev libgnomeui-dev libgstreamer0.10-dev libxml-parser-perl libssl-dev
  • Then uncompress and patch the sources
 tar zxvf g2ipmsg_0.9.6+dfsg.orig.tar.gz gunzip g2ipmsg_0.9.6+dfsg-1.1.diff.gz patch -p0 < g2ipmsg_0.9.6+dfsg-1.1.diff
  • Compile to create deb packages
cd g2ipmsg-0.9.6+dfsg/debuild -us -uc
  • Install the deb package
cd ..sudo dpkg -i g2ipmsg_0.9.6+dfsg-1.1_i386.deb

Note – if you are compiling 64bit – then the package name will end in amd64.deb


Linked Question:

  1. How to open aMSN that has been minimised to the tray?

When you see an error message like that from pkg-config (“No package ‘foo’ found”), that means that the file foo.pc cannot be found by pkg-config. The usual reason for this is that you don’t have the package which provides this file installed, so you should search either using apt-file or on packages.ubuntu.com for it. In this specific case however, you’ll get no results because the old GNOME 2 panel applets have all been removed.

If you pass --disable-applet to ./configure, you should be able to get past this step.

A basic method for going through the dependencies of a piece of software you are trying to build from the source is as follows:

  1. Try to compile the code until it complains, then look at the error message and try to figure out what the missing package may be called

  2. Use the command apt-cache search to help you locate the packages you need – the shorter the , the better chances of finding matching package names/descriptions

  3. The packages you need to install are almost always named lib...-dev in Ubuntu/Debian; install the relevant package listed by apt-cache using sudo apt-get install and go back to step 1

So for instance, if you’re looking for the “libpanelapplet” package, running apt-cache search libpanel will return:

gir1.2-panelapplet-4.0 - GObject introspection for the GNOME Panel Applet librarygnome-panel-dbg - GNOME Panel and library for panel applets - debugging symbolslibpanel-applet-4-0 - library for GNOME Panel appletslibpanel-applet-4-dev - library for GNOME Panel applets - development fileslibpanel-applet-4-doc - library for GNOME Panel applets - documentation files

of which libpanel-applet-4-dev should contain the development headers you are looking for. (Note: the above output is on Precise, the version in Oneiric might have a different name.)

Share

Advertisement

Comment