1:54 - Friday, 25 April 2014

Php 5.4 Configure Edit Library Required By Readline

Trying to compile PHP 5.4, and for some reason cannot solve this problem:

checking for libedit readline replacement... yeschecking for tgetent in -lncurses... nochecking for tgetent in -ltermcap... nochecking for readline in -ledit... noconfigure: error: edit library required by readline not found

My configure command is this:

./configure –with-libdir=lib64 –with-openssl –enable-fpm
–with-mcrypt –with-apxs2=/usr/sbin/apxs –enable-cli –with-config-file-path=/etc –with-libxml-dir=/usr –with-kerberos=/usr –with-zlib=/usr –enable-bcmath –with-bz2=/usr –enable-calendar –with-curl=/usr –enable-dba –enable-exif –enable-ftp –with-gd –enable-gd-native-ttf –with-icu-dir=/usr –with-iodbc=/usr –with-ldap –with-ldap-sasl=/usr –with-readline –with-libedit –enable-mbstring –enable-mbregex –with-mysql=mysqlnd –with-mysqli=mysqlnd –without-pear –with-pdo-mysql=mysqlnd –with-mysql-sock=/tmp/mysql.sock –enable-shmop –with-snmp=/usr –enable-soap –enable-sockets –enable-sysvmsg –enable-sysvsem –enable-sysvshm –with-tidy –enable-wddx –with-xmlrpc –with-iconv-dir=/usr –with-xsl=/usr –enable-zip –with-pcre-regex –with-freetype-dir=/usr/X11 –with-jpeg-dir=/usr –with-png-dir=/usr/X11

Trying to compile on AWS Amazon EC2 server. Googled the heck out of it, still cannot solve.
I already installed:

libedit.x86_64libedit-devel.x86_64readline.x86_64readline-devel.x86_64

and still does not help. Does anybody have any clue what else I can try?

Share

Advertisement

Comment